Instalar paquetes en versiones de CentOS antiguas

Instalando la versión 4.8 de CentOS encontré siempre el mismo mensaje cada vez que quería instalar o actualizar el sistema:

not using ftp, http[s], or file for repos, skipping - 
4 is not a valid release or hasnt been released yet

Esto se debe a que la versión de CentOS ha llegado al final de su ciclo de vida (EOL) y ya no se mantiene, por lo que las urls de los repositorios se encuentran apuntando a donde están las releases mantenidas, donde ya no se encuentra el repositorio.

Hay que cambiar las url de los repositorios para que apunten a los repositorios vault de Centos. En este caso http://vault.centos.org/4.8/os/$basearch

Los pasos son:

  1. Abrir /etc/yum.repos.d/CentOS-Base.repo
  2. Descomentar las entradas “mirrorlist”
  3. Desomenctar las entradas “baseurl” y cambiarlas a “http://vault.centos.org/4.8/os/$basearch”

Con esto, ya podremos actualizar e instalar los paquetes correspondientes.

Si tu distribución es diferente, solo es necesario cambiar el número de la versión en la url, ya que los repositorios vault guardan todas las distribuciones que ya no tienen soporte.

Fuente: http://www.ngdcorp.com/blog/solutions/centos-4-end-of-life

Anuncios

2 pensamientos en “Instalar paquetes en versiones de CentOS antiguas

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s